How does Call History work?

FocusCura -

Problem

I see calls with a duration of 00:00:00 in Call History in the cContact Backoffice

Cause

To understand the problem we would like to explain to you how we measure call duration in the app cContact.


When a call is initiated, a call of 0:00:00 is entered in the call log and the app starts a timer. On iPad we use FaceTime to initiate the call from our app cContact. The call duration is only updated in the log when you return to the app cContact after a call. This is because cContact and FaceTime are two separate apps on your iPad and the app cContact is doing the logging of the call duration. So when you kill the app cContact or switch off the iPad before it can update the log, the call duration will remain 0:00:00.

callduration.png

Solution

Always return to the app cContact after a call

  • Don't press the home button after a call
  • Don't switch off your iPad after a call
  • Don't close (kill) the app cContact after a call

Call History Reporting in the cContact Backoffice

  • The maximum ringing time for FaceTime is 30 seconds. Ringing time is also counted as call duration. FaceTime doesn't log if the call is answered or not. To have more accurate call history we advice the filter out calls wit a call duration below 30 seconds
  • Calls with a duration below 10 seconds are reported as 00:00:00 in the call history.

 

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